Fixed: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference

Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in /libraries/joomla/cache/handler/callback.php on line 99

Jika terdapat tampilan pesan error di atas, pada website joomla yang telah Anda install dan sebelumnya berjalan dengan baik, jangan panik terlebih dahulu, karena pesan error ini bisa ditangani.

Pesan error ini tampil karena versi Joomla yang Anda gunakan ketika membangun website tidak kompatibel dengan PHP 5.3.0, Umumnya terjadi ketika perusahaan hosting mengupgrade versi PHP menjadi versi 5.3.0

Salah satu solusinya bisa mengikuti cara berikut:

Masuk ke dalam akun hosting Anda, lalu pada direktori root modules/mod_mainmenu/ cari file dengan nama helper.php kemudian edit file tersebut.

Lihat di bagian atas file helper.php, ubah baris

menjadi

Lengkapnya sebagai berikut:

menjadi

Kemudian simpan file helper.php tersebut.

Baca Juga:  Ini Alasan Sederhana Wordpress Anda Mudah Diretas
Harga Domain .ID Termurah Hanya 199rb

Di tulis oleh: